你的位置:首页 > 信息动态 > 新闻中心
信息动态
联系我们

计算机网络课程设计

2021-12-3 23:41:50

《计算机网络》课程设计报告书

班级:

姓名:

学号:

指导教师:

2020年 12 月 15 日

目录

一、课程设计内容

二、相关理论

三、设计方案

3.1 设备选择

3.2 IP地址规划设计

3.3 网络拓扑结构

四、设计步骤

4.1 基础配置:

4.2 交换部分配置要求:

4.3 路由部分配置要求:

4.4 广域网部分:

五、结果分析

六、问题及解决办法

七、个人心得体会

八、参考资料

九、附录

9.1 配置文件:

9.2 详细步骤:


一、课程设计内容

某中小型企业,有两个部门,销售部(VLAN10)与行政部(VLAN20),其中销售部有13台主机,行政部有7台主机。同部门之间采用二层交换网络相连,不同部门之间采用单臂路由方式跨VLAN互访。

企业有一台内部Web服务器,承载着内部网站,方便员工了解公司的即时信息;局域网路由器选用动态路由协议。企业有一条专线接到运营商用以连接互联网,采用PPP封装,由于从运营商只获取到一个公网IP地址,所以企业员工上网需要做NAT网络地址转换。

二、相关理论

为路由器写入路由表

在交换机上划分并管理VLAN

RIP协议的配置

NAT网配置

帧中继云配置

PPP协议的配置

三、设计方案

3.1 设备选择

服务器:Server-PT×1

主机:PC-PT×20

路由器:DCE2811×6

集线器:2960-24Router×2

云:Cloud-PT×1

DCE串口线×5

3.2 IP地址规划设计

 

主要IP划分:

服务器:10.10.10.10

PC1-14:vlan10

192.168.1.0

PC15-20:vlan20

192.168.2.0

运营商:200.1.1.2

3.3 网络拓扑结构

 

四、设计步骤

4.1 基础配置:

参考上图的模拟环境拓扑,在PT中搭建网络,具体要求如下:

4.1.1 参考上图,为两个部门的主机分配适当的IP地址及默认网关,其中,PC0~PC14为销售部的主机,PC15~PC20为行政部的主机;为Web服务器配置IP地址及默认网关;

4.1.2 为交换机Switch1,Switch2分别命名为:学号_Sw1、学号_Sw2;在Sw1/ Sw2上设置特权用户访问密码cisco;

4.1.3 为路由器Router1,Router2,Router3,Router4,Router6分别命名为:学号_R1、学号_R2、学号_R3、学号_R4、学号_R6;配置路由器R1/R2/R3/R4/R6各个接口;

4.2 交换部分配置要求:

4.2.1 [Trunk]:Sw1与Sw2的相关接口封装为Trunk;

4.2.2 [VLAN]:创建VLAN10,命名为Sales;VLAN20,命名为Admin;并把相应的接口划分到所属VLAN中;

4.2.3 [管理VLAN/访问控制]:在Sw1上设置管理VLAN10,地址为192.168.1.100/24;在Sw2上设置管理VLAN20,地址为192.168.2.100/24;

4.2.4 [单臂路由]:配置单臂路由,VLAN 10以R1的F0/1.10作为出口网关;VLAN20以R3的F0/0.20作为出口网关;

4.3 路由部分配置要求:

4.3.1 [默认路由]:在R4上配置默认路由,出口指向运营商;

4.3.2 [动态路由]:在R1/R2/R3/R4/R6上配置RIPv2,关闭自动汇总,使得全网互通(R4与运营商R5的S1/1 S1/0接口不宣告);

4.3.3 [ACL]:在R1上做ACL访问限制,所有用户都可以ping通Server。除PC1和PC16以外,其他用户都可以访问内部网站;

4.4 广域网部分:

4.4.1 [NAT]:在R4上配置NAT,使得企业内部所有PC都能上网(ping通运营商的200.1.1.2),Server不能连接外网;

4.4.2 [帧中继云配置]:在R5和R4之间配置帧中继;

4.4.3 [PPP]:R1/R2的串行链路封装为PPP,做PAP认证,R1为R2创建用户名USERR2,密码为pwd2;R2为R1创建用户名USERR1,密码为pwd1;

五、结果分析

在内网中,通过Trunk的配置,VLAN的划分,管理VLAN/访问控制,单臂路由的配置后可以实现主机到服务器的ping通操作。

通过ALC配置,可以限制主机之间的访问权限。

在广域网中,通过NAT的配置,帧中继云的配置,可以实现主机到运营商的ping通。

六、问题及解决办法

什么是VLAN,划分VLAN的作用是什么?

VLAN是英文Virtual Local Area Network的简称,又叫虚拟局域网,是一种通过将局域网内的设备逻辑地而不是物理地划分成一个个网段从而实现虚拟工作组的技术。

VLAN是为解决以太网的广播问题和安全性而提出的,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中。本项目中即使是处在相同部门的网段之间的PC机,但PC1-10与PC11-14不在同一VLAN中,它们各自的广播流也不会相互转发。

交换机VLAN 模式trunk和access 区别是什么?

         Access端口一般用于连接用户计算机;Access端口只能属于一个VLAN。

Trunk端口一般用于交换机之间或交换机与路由器之间的互连。

创建VLAN相关命令

w_Sw1#configure terminal

w_Sw1(config)#vlan 10  //在交换机Sw1上创建VLAN10

w_Sw1(config-vlan)#name Sales

什么是默认网关

默认网关的意思是一台主机如果找不到可用的网关,就把数据包发给默认指定的网关,由这个网关来处理数据包。

什么是默认路由?

当互联网络中路由器的每个接口设置适当的IP地址后,要使该互联网络中的每个网络之间能够相互通信,必须将互联网络中的每个网络添加到每个路由器的路由表中。

默认路由是路由表中与目的地址之间没有匹配的表项时,路由器能够选择下一跳地址。

默认路由配置相关命令

w_R4#configure terminal

w_R4(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2  //配置默认路由,出口指向200.1.1.2

w_R4(config)#router rip

w_R4(config-router)#default-information originate  //默认路由宣告

遇到的问题:在实验中,最开始只配置了默认路由,而没有进行路由宣告,导致PC机无法连接运营商。进行tracert命令跟踪IP数据包访问目标所采取的路径发现数据包总在传到路由器R1/R2/R3时断开连接。

解决方案:在对R4添加了default-information originate代码后,通过在路由器R2中的show ip route命令查看发现多了一行路由表信息:R*   0.0.0.0/0 [120/2] via 10.2.2.3, 00:00:15, Serial1/1

由此可见路由宣告可以使内网路由器得到一条去往边界的路由的方案。

为什么要配置单臂路由?

换机设置成两个VLAN时,逻辑上已经成为两个网络,广播被隔离了。两个VLAN的网络要通信,必须通过路由器,如果接入路由器的只有一个物理端口,则必须有两个子接口分别与两个VLAN对应,同时还要求与路由器相连的交换机的端口要设置为trunk,因为这个口要通过两个VLAN的数据包。

单臂路由配置相关命令

w_R1#configure terminal

w_R1(config)#interface fastEthernet 0/0

w_R1(config-if)#no shutdown  //开启父接口

w_R1(config-if)#exit

w_R1(config)#interface fastEthernet 0/0.10  //进入子接口

w_R1(config-subif)#encapsulation dot1Q 10  // Trunk的封装类型设置为802.1Q

w_R1(config-subif)#ip address 192.168.1.254 255.255.255.0

w_R1(config-subif)#no shutdown

动态路由及RIP协议的特点?

本项目采用协议为RIP协议,RIP协议是一种动态路由协议。

动态路由协议通过路由信息的交换生成并维护转发引擎需要的路由表。动态路由协议的优点是可以自动适应网络状态的变化,自动维护路由信息而不用网络管理员的参与。网络拓扑结构改变时自动更新路由表,并负责决定数据传输最佳路径。

仅和相邻的路由器交换信息。

路由器交换的信息是当前本路由器知道的全部信息,即自己的路由表。

按固定时间交换路由信息。

采用距离向量路由选择算法,即认为所经过路由器数目最少的路径为最佳路径。

使用RIP协议时,需要将此路由器周围所有的网段写入路由表。

ACL的目的及实现

ACL访问控制列表是一种基于包过滤的访问控制技术,它可以根据设定的条件对接口上的数据包进行过滤,允许其通过或丢弃。

在本项目中有两个地方使用了ACL,第一个是在R1上限制PC1和PC20访问服务器;第二个是在R4上限值服务器访问运营商。

ACL配置相关命令

w_R1#configure terminal

w_R1(config)#access-list 100 deny ip host 192.168.1.1 host 10.10.10.10  //创建访问限制表,限制PC1访问内部网站

w_R1(config)#access-list 100 deny ip host 192.168.2.20 host 10.10.10.1  //创建访问限制表,限制PC20访问内部网站

w_R1(config)#access-list 100 permit ip any any  //允许所有IP流量

w_R1(config)#interface serial 1/0

w_R1(config-if)#ip access-group 100 out  //将列表10所定义的条件应用禁止从此接口出去

帧中继的概念及配置

帧中继相当于路由功能,能把一些网络连接起来。

本实验采用帧中继连接内网和外网。

帧中继的配置需要为中继云分别配置两个DLCI号。可以在中继云配置的接口中进行配置,还可以通过frame-relay map ip address dlci [broadcast] [ietf] [cisco]命令进行配置。其中:

address远程节点接口的IP地址。

 dlci本地接口的DLCI号。

broadcast:允许在VC上广播或组播,此参数允许在VC上使用动态路由协议。

ietf:在连接到非Cisco路由器时要使用该参数。

帧中继相关命令

w_R4#configure terminal

w_R4(config)#interface serial 1/0

w_R4(config-if)#encapsulation frame-relay  //设置接口的封装模式为frame-relay

w_R4(config-if)#frame-relay lmi-type cisco  //设置帧中继的lmi类型为cisco

NAT的概念及作用

NAT即为Network Address Translation,中文意思是“网络地址转换”。

NAT的特点:

1、宽带分享:这是 NAT 主机的最大功能。

2、安全防护:NAT 之内的 PC 联机到 Internet 上面时,他所显示的 IP NAT 主机的公共 IP,所以 Client 端的 PC 当然就具有一定程度的安全了,外界在进行 Portscan(端口扫描) 的时候,就侦测不到源Client 端的 PC

本实验采用端口多路复用技术:及改变外出数据包的源端口并进行端口转换,即端口地址转换(PAT,Port Address Translation)。

w_R4#configure terminal

w_R4(config)#interface range fastEthernet 0/0 - 1

w_R(config-if-range)#ip nat inside  //定义NAT内部接口

w_R(config-if-range)#exit

w_R4(config)#interface serial 1/0

w_R4(config-if)#ip nat outside  //定义NAT外部接口

w_R4(config-if)#exit

w_R4(config)#ip nat inside source list 1 interface serial 1/0 overload  //启用内部源地址转换的动态NAT

转换后,内部网络的所有主机均可共享一个合法外部IP地址实现对Internet的访问,从而可以最大限度地节约IP地址资源。

七、个人心得体会

路由器是一种典型的网络层设备。它是两个局域网之间接“帧”传输数据, 在OSI/RM之中被称之为中介系统,完成网络层中继或第三层中继的任务。路由器负责在两个局域网的网络层间接“帧”传输数据,转发“帧”时需要查找地址。

路由器是用于连接多个逻辑上分开的网络,所谓逻辑网络是代表一个单独的网络或者一个子网。

NAT不仅能解决IP地址不足的问题,而且还能够有效地避免来自网络外部的攻击,隐藏并保护网络内部的计算机。

帧中继的交换设备在用户路由器间建立虚电路。提供基于分组的二层通道。

八、参考资料

Cisco故障排除说明

Packet Tracer实验全集

百度

CSDN

计算机网络教材

九、附录

9.1 配置文件:

9.2 详细步骤:

1、基础配置

1.1 根据3.3的网络拓扑在Packet Tracer中搭建网络

1.2 如下图所示,为各个部门的主机分配适当的IP地址及默认网关,其中,PC0-14为销售部主机,个人PC15-20为行政部的主机;为Web服务器配置IP地址及默认网关

为主机配置IP地址及其默认网关  //其他主机配置操作类似,注意地址的准确划分

 

为服务其配置IP地址及其默认网关

 

1.3 为两个交换机配置名称及设置特权用户访问密码cisco

设置Switch1的配置名称及特权用户访问密码相关命令  //Sw2配置操作类似

Switch#configure terminal

Switch(config)#hostname w_Sw1

w_Sw1(config)#enable password cisco

1.4 为路由器配置名称

设置路由器名称  //下列代码为R1的配置,R2/R3/R4/R6配置相同

Router#configure terminal

Router(config)#hostname w_R1

w_R1(config)#

1.5 分别配置路由器R1/R2/R3/R4/R6的各个接口

R1接口的配置

w_R1#configure terminal

w_R1(config)#interface serial 1/0  //R1R6直接接口IP配置

w_R1(config-if)#ip address 10.10.20.13 255.255.255.0

w_R1(config-if)#no shutdown  //开启接口

w_R1(config-if)#exit

w_R1(config)#interface serial 1/1  //R1R2之间接口IP配置

w_R1(config-if)#ip address 10.1.1.1 255.255.255.0

w_R1(config-if)#no shutdown

w_R1(config-if)#clock rate 64000  //时钟配置

w_R1(config-if)#exit

w_R1(config)#interface fastEthernet 0/1  //R1R4之间接口IP配置

w_R1(config-if)#ip address 172.16.1.1 255.255.255.0

w_R1(config-if)#no shutdown

R2接口的配置

w_R2#configure terminal

w_R2(config)#interface serial 1/0  //R2R1之间接口IP配置

w_R2(config-if)#ip address 10.1.1.2 255.255.255.0

w_R2(config-if)#no shutdown

w_R2(config-if)#exit

w_R2(config)#interface serial 1/1  //R2R3之间接口IP配置

w_R2(config-if)#ip address 10.2.2.2 255.255.255.0

w_R2(config-if)#no shutdown

w_R2(config-if)#clock rate 64000  //时钟配置

R3接口的配置

w_R3#configure terminal

w_R3(config)#interface serial 1/0  //R3R2之间接口IP配置

w_R3(config-if)#ip address 10.2.2.3 255.255.255.0

w_R3(config-if)#no shutdown

w_R3(config-if)#exit

w_R3(config)#interface fastEthernet 0/1  //R3R4之间接口IP配置

w_R3(config-if)#ip address 172.16.4.1 255.255.255.0

w_R3(config-if)#no shutdown

R4接口的配置

w_R4#configure terminal

w_R4(config)#interface fastEthernet 0/0  //R4R1之间接口IP配置

w_R4(config-if)#ip address 172.16.1.4 255.255.255.0

w_R4(config-if)#no shutdown

w_R4(config-if)#exit

w_R4(config)#interface fastEthernet 0/1  //R4R3之间接口IP配置

w_R4(config-if)#ip address 172.16.2.4 255.255.255.0

w_R4(config-if)#no shutdown

w_R4(config-if)#exit

w_R4(config)#interface serial 1/0  //R1R5之间接口IP配置

w_R4(config-if)#ip address 200.1.1.1 255.255.255.0

w_R4(config-if)#no shutdown

R5接口的配置

Router#configure terminal

Router(config)#interface serial 1/0  //R5R4之间接口IP配置

Router(config-if)#ip address 200.1.1.2 255.255.255.0

Router(config-if) #no shutdown

Router(config-if)#clock rate 64000  //时钟配置

R6接口的配置

w_R6#configure terminal

w_R6(config)#interface fastEthernet 0/0  //R6与服务器之间接口IP配置

w_R6(config-if)#ip address 10.10.10.11 255.255.255.0

w_R6(config-if)#no shutdown

w_R6(config-if)#exit

w_R6(config)#interface serial 1/0  //R6R1之间接口IP配置

w_R6(config-if)#ip address 10.10.20.12 255.255.255.0

w_R6(config-if)#no shutdown

w_R6(config-if)#clock rate 64000  //时钟配置

2、交换机

2.1 Trunk

将Sw0与Sw1的相关接口分装成trunk,将两个交换机之间的接口分装为trunk

Sw1交换机的接口模式

w_Sw1#configure terminal

w_Sw1(config)#interface fastEthernet 0/24

w_Sw1(config-if)#switchport mode trunk

w_Sw1(config-if)#exit

w_Sw1(config)#interface fastEthernet 0/21

w_Sw1(config-if)#switchport mode trunk

Sw2交换机的接口模式

w_Sw2#configure terminal

w_Sw2(config)#interface fastEthernet 0/24

w_Sw2(config-if)#switchport mode trunk

w_Sw2(config-if)#exit

w_Sw2(config)#interface fastEthernet 0/21

w_Sw2(config-if)#switchport mode trunk

2.2 VLAN划分

分别为两个交换机创建两个VLAN,VLAN10命名为Sales,VLAN20命名为Admin,并将192.168.1.0的主机划入vlan10中,将192.168.2.0的主机划入vlan20中

为Sw1创建VLAN10和VLAN20  //Sw1分配两个VLAN,并将相关接口划入VLAN

w_Sw1#configure terminal

w_Sw1(config)#vlan 10  //创建VLAN10

w_Sw1(config-vlan)#name Sales

w_Sw1(config-vlan)#exit

w_Sw1(config)#interface range fastEthernet 0/1 - 10

w_S(config-if-range)#switchport mode access

w_S(config-if-range)#switchport access vlan 10  //把相应接口划入VLAN

w_S(config-if-range)#exit

w_Sw1(config)#vlan 20  //创建VLAN20

w_Sw1(config-vlan)#name Admin

w_Sw1(config-vlan)#exit

w_Sw1(config)#interface range fastEthernet 0/15 - 17

w_S(config-if-range)#switchport mode access

w_S(config-if-range)#switchport access vlan 20  //把相应接口划入VLAN

为Sw2创建VLAN10和VLAN20  //Sw2分配两个VLAN,并将相关接口划入VLAN

w_Sw2#configure terminal

w_Sw2(config)#vlan 10  //创建VLAN10

w_Sw2(config-vlan)#name Sales

w_Sw2(config-vlan)#exit

w_Sw2(config)#interface range fastEthernet 0/11 - 14

w_S(config-if-range)#switchport mode access

w_S(config-if-range)#switchport access vlan 10  //把相应接口划入VLAN

w_S(config-if-range)#exit

w_Sw2(config)#vlan 20  //创建VLAN20

w_Sw2(config-vlan)#name Admin

w_Sw2(config-vlan)#exit

w_Sw2(config)#interface range fastEthernet 0/18 - 20

w_S(config-if-range)#switchport mode access

w_S(config-if-range)#switchport access vlan 20  //把相应接口划入VLAN

2.3 管理VLAN/访问控制

在Sw0上设置管理VLAN10,地址为192.168.1.100

Sw1上的管理VLAN与访问控制

w_Sw1#configure terminal

w_Sw1(config)#interface vlan 10

w_Sw1(config-if)#ip address 192.168.1.100 255.255.255.0

w_Sw1(config-if)#no shutdown

Sw2上的管理VLAN与访问控制

w_Sw2#configure terminal

w_Sw2(config)#interface vlan 20

w_Sw2(config-if)#ip address 192.168.2.100 255.255.255.0

w_Sw2(config-if)#no shutdown

3、路由器的配置

3.1 单臂路由

R1单臂路由子接口的配置  //VLAN10R1f0/21作为出口网关

w_R1#configure terminal

w_R1(config)#interface fastEthernet 0/0

w_R1(config-if)#no shutdown  //开启父接口

w_R1(config-if)#exit

w_R1(config)#interface fastEthernet 0/0.10

w_R1(config-subif)#encapsulation dot1Q 10  // Trunk的封装类型设置为802.1Q

w_R1(config-subif)#ip address 192.168.1.254 255.255.255.0

w_R1(config-subif)#no shutdown

R3单臂路由子接口的配置  //VLAN20R3f0/21作为出口网关

w_R3#configure terminal

w_R3(config)#interface fastEthernet 0/0

w_R3(config-if)#no shutdown  //开启父接口

w_R3(config-if)#exit

w_R3(config)#interface fastEthernet 0/0.20

w_R3(config-subif)#encapsulation dot1Q 20  // Trunk的封装类型设置为802.1Q

w_R3(config-subif)#ip address 192.168.2.254 255.255.255.0

w_R3(config-subif)#no shutdown

3.2 动态路由

3.2.1 为R4配置默认路由

R4默认路由的配置  //出口指向运营商200.1.1.2

w_R4#configure terminal

w_R4(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2  //配置默认路由

w_R4(config)#router rip

w_R4(config-router)#default-information originate  //默认路由宣告

3.2.2 在R1/R2/R3/R4/R6上配置RIPv2

R1的RIP协议的配置

w_R1#configure terminal

w_R1(config)#router rip

w_R1(config-router)#version 2

w_R1(config-router)#no auto-summary  //关闭自动汇总

w_R1(config-router)#network 192.168.1.0

w_R1(config-router)#network 192.168.2.0

w_R1(config-router)#network 172.16.1.0

w_R1(config-router)#network 10.0.0.0

R2的RIP协议的配置

w_R2#configure terminal

w_R2(config)#router rip

w_R2(config-router)#version 2

w_R2(config-router)#no auto-summary  //关闭自动汇总

w_R2(config-router)#network 10.0.0.0

R3的RIP协议的配置

w_R3#configure terminal

w_R3(config)#router rip

w_R3(config-router)#version 2

w_R3(config-router)#no auto-summary  //关闭自动汇总

w_R3(config-router)#network 192.168.2.0

w_R3(config-router)#network 192.168.1.0

w_R3(config-router)#network 172.16.2.0

w_R3(config-router)#network 10.0.0.0

R4的RIP协议的配置  //R4与运营商R5s1/0s1/1接口不宣告

w_R4#configure terminal

w_R4(config)#router rip

w_R4(config-router)#version 2

w_R4(config-router)#no auto-summary  //关闭自动汇总

w_R4(config-router)#network 172.16.0.0

R6的RIP协议的配置

w_R6#configure terminal

w_R6(config)#router rip

w_R6(config-router)#version 2

w_R6(config-router)#no auto-summary  //关闭自动汇总

w_R6(config-router)#network 10.0.0.0

3.2.3 RIP配置完成后进行不同网段的ping通测试

PC2(192.168.1.2)ping通PC20(192.168.2.20

 

3.3 ACL

3.3.1 在R1上左ACL访问限制,所有主机都可以ping通Server;除PC1和PC20以外,其他用户都可以访问内部网站

R1上ACL的配置  //PC1PC20以外,其他PC都可以访问内部网站

w_R1#configure terminal

w_R1(config)#access-list 100 deny ip host 192.168.1.1 host 10.10.10.10  //创建访问限制表,限制PC1访问内部网站

w_R1(config)#access-list 100 deny ip host 192.168.2.20 host 10.10.10.10  //创建访问限制表,限制PC20访问内部网站

w_R1(config)#access-list 100 permit ip any any  //允许所有IP流量

w_R1(config)#interface serial 1/0

w_R1(config-if)#ip access-group 100 out  //将列表10所定义的条件应用禁止从此接口出去

3.3.2 ACL配置完成后进行主机与服务器的ping通实验

使用PC1(192.168.1.1)和PC20(192.168.2.20)ping通服务器:

 

 

使用其他主机ping通服务器,PC5(192.168.1.5)ping通服务器

 

注:至此内网PC全部互联,除PC1和PC20其余均可以访问内部网站

4、广域网

4.1 帧中继云配置

添加DLCI  //分别为中继云的两个接口添加DLCI

 

 

连接两个端口  //连接创建的DLCI

 

在R4上分装帧中继

w_R4#configure terminal

w_R4(config)#interface serial 1/0

w_R4(config-if)#encapsulation frame-relay  //设置接口的封装模式为frame-relay

w_R4(config-if)#frame-relay lmi-type cisco  //设置帧中继的lmi类型为cisco

在R5上分装帧中继

w_R5#configure terminal

w_R5(config)#interface serial 1/0

w_R5(config-if)#encapsulation frame-relay  //设置接口的封装模式为frame-relay

w_R5(config-if)#frame-relay lmi-type cisco  //设置帧中继的lmi类型为cisco

4.2 NAT配置

在R4上进行NAT的配置

w_R4#configure terminal

w_R4(config)#interface range fastEthernet 0/0 - 1

w_R(config-if-range)#ip nat inside  //定义NAT内部接口

w_R(config-if-range)#exit

w_R4(config)#interface serial 1/0

w_R4(config-if)#ip nat outside  //定义NAT外部接口

w_R4(config-if)#exit

w_R4(config)#access-list 1 deny host 10.10.10.10  //禁止服务器连接外网

w_R4(config)#access-list 1 permit any  //允许所有用户通过

w_R4(config)#ip nat inside source list 1 interface serial 1/0 overload  //启用内部源地址转换的动态NAT

4.3 PPP

在R1与R2之间的串行链路分装为PPP

w_R1(config)#username USERR2 password pwd2  //创建路由器PPP名字和密码

w_R2(config)#username USERR1 password pwd1

w_R1(config)#interface serial 1/1

w_R1(config-if)#encapsulation ppp  //PPP协议的封装

w_R1(config-if)#ppp authentication pap  //启用PAP认证方式

w_R1(config-if)#ppp pap sent-username UESRR1 password pwd1   //启用出站PAP身份验证

w_R2(config)#interface serial 1/0

w_R2(config-if)#encapsulation ppp

w_R2(config-if)#ppp authentication pap

w_R2(config-if)#ppp pap sent-username UESRR2 password pwd2

注:此时内网的所有主机都可以ping通运营商(200.1.1.2)

PC1(192.168.1.1)ping通运营商(200.1.1.2)测试